Peavey Vypyr Tube 60

Amp setups, pedal signal chains, and more.
Post Reply
User avatar
Fly Rod
Full Member
Posts: 153
Joined: Tue Sep 07, 2021 8:44 am
Location: The Wood Shed

Peavey Vypyr Tube 60

Post by Fly Rod »

My Son's #1 Guitar Amp is a Peavey Vypyr Tube 60
It started hissing & We assumed it was one of the tubes even though none seemed to be microphonic by the tap test with a chopstick
It had Ruby Tubes = 1 12AX7 & 2 6L6GC We installed three new JJ Tubes & the sound is still there, I looked it over closely & see nothing that looks troubling like a swollen capacitor, The input jack was loose so I tightened it with a 12mm socket..
Just got done with it & haven't even plugged it back in or tested it but KNOW that it's still doing it..
What really sucks is I bought a Sanpera II pedal for this amp for him for Christmas & have it on Lay-A-Way at the Pawn Shop
Only Paid a $100 for the $250 Pedal BTW..
Pray for the Peavey Vypyr Tube 60 didn't want to spend another $150 for the 75 Watt Solid State Amp with less Tone..
Gary
FLY ROD Formerly FLY Wheel
User avatar
Fly Rod
Full Member
Posts: 153
Joined: Tue Sep 07, 2021 8:44 am
Location: The Wood Shed

Re: Peavey Vypyr Tube 60

Post by Fly Rod »

Hey I fixed it like a Master Amp Tech = Yes Sir!! :D
The "Hissing & Buzz" Is Gone = OH YEAH!!
Even seems more powerful & has a slightly different fuller tone because of the Tube Brand Change
Total Cost of the three tubes was $60 for the JJs from Tube Depot & took two days from order time to our door
I'm So Happy!! & My Son learned a bunch helping me too..
Peavey Vypyr Tube 60.jpg
Peavey Sanpera II Pedal Coming for Christmas
R.jpg
50d590b70a5287ad57f14792f76a4d3b.jpg
We Should bring an amp onto the porch & Play Electric Funeral for the Neighborhood Kids
That Deep Dark Distortion on the Jackson DK2M Pile-O-Skulls
P5140002.JPG
Bought this Body with the trem from Maxwell's House of Music for $75 & then found a neck & loaded the body with pickups from the stash & "It LIVES"
HAPPY HALLOWEEN
FLY ROD Formerly FLY Wheel
mmmguitar
Forum Veteran
Posts: 484
Joined: Tue Oct 01, 2019 1:25 am
Contact:

Re: Peavey Vypyr Tube 60

Post by mmmguitar »

So did a tube end up being the issue, @Fly Rod? I didn’t reply when you made the original post but, a cursory trip down the Google rabbit hole while I was at work that day brought up a few threads in which people complained that mediocre soldering at the input jack was a common culprit causing hiss in the Vyper series. I used to subcontract a Peavey dealer, but never had an amp with that particular issue show up on my workbench. So I’m curious to know if there was an issue I could have looked out for at the time, had I known.
User avatar
Fly Rod
Full Member
Posts: 153
Joined: Tue Sep 07, 2021 8:44 am
Location: The Wood Shed

Re: Peavey Vypyr Tube 60

Post by Fly Rod »

The input jacks nut was loose the tiny board was moving around some
I tightened the nut & put a drop of hot glue on the board + replaced the tubes
JFYI the Tubes where all good IMO
Thanks for the reply @mmmguitar
FLY ROD Formerly FLY Wheel
Post Reply